A suggested revision for UCDs
jcm at head-cfa.cfa.harvard.edu
Thu Oct 23 06:54:18 PDT 2003
Now that I've read the document and absorbed at least
some of the emails, I must say that I like your proposal
a lot. Although there are certainly details to be cleaned
up, and I agree with most of Norman's and some of Bob's comments,
it feels to me a more solid basis for a UCD2.
My biggest beef (which goes directly against Norman's prejudice
that UCDs are not an object model!) is that I don't like the
distinction between "value" and "instance", especially
given that array-valued "values" like "spectrum.value" are
mentioned by you. I think your instance is just the value
of a higher level term, and I would like to replace "pos.instance"
with "pos.value", and then immediately drop the optional ".value"
and just say "pos". Why is that a bad idea?
Thanks for doing this work!
More information about the ucd